2017/10/29

Buffalo WZR-600DHP DIAGランプ2回点滅

自分用メモ
真似する人は、自己責任でお願いします。

DIAGランプ 2回点滅 = フラッシュROM異常

用意するもの
・WZR-HP-AG300Hのファーム 1.73
http://buffalo.jp/download/driver/lan/old/wzr-hp-ag300h-win.html
 (1.73以下でないと、後に「WZR-600DHPのファーム」に書き直すためのDebugモードに入れない)
 (WZR-HP-AG300Hと、WZR-600DHPは、同じハードウェアで型番違いだけ?)
 (WZR-600DHPのファームは、暗号化?されていて、TFTPから、書き込むことができない?)

・WZR-600DHPのファーム 1.99(最新)
http://buffalo.jp/download/driver/lan/wzr-600dhp_fw-win.html

 cドライブ直下に「1」というフォルダを作り、ファームファイルのみコピーしておく

手順

1.windows7 TFTPを有効にしておく

2.PC側、IPアドレスを(192.168.11.2) マスク(255.255.255.0)に変更

3.cmd(管理者モード)にて、
1)準備
arp -s 192.168.11.1 02-aa-bb-cc-dd-20
netsh interface ipv4 set neighbors "ローカル エリア接続" 192.168.11.1 02-aa-bb-cc-dd-20

2)転送
tftp -i 192.168.11.1 put c:\1\wzr_hp_ag300h_jp_173

ルーター電源オン 背面のLEDランプの状況を見ながら、、
USB横LED 点灯
LAN LED 全部 点灯
LAN1(PCに接続してある)LED 点灯
の直後に、「転送」コマンドを入力
「タイムアウト」がでたら、失敗なので、
ルーター電源再投入、「転送」コマンドを入力するタイミングを変えてみる。
(当方は、10回目ぐらいに成功した。)

3)事後
netsh interface ipv4 delete neighbors "ローカル エリア接続"
arp -d 192.168.11.1

「転送を正常に完了しました」がでたら、「事後」処理しておく。
(これをしておかないと、ルーターの管理画面に入れない)

6.DIAGランプが消えるまで待つ。
PC、ブラウザから、「192.168.11.1」
ID:bufpy、パスワード:otdpopy
「管理設定」「本体」のメニューから、「/cgi-bin/cgi?req=frm&frm=py-db/firmup.html」をクリック
「WZR-600DHPのファーム」を選択、[OK]をクリック
6分間、ファーム書き換え完了まで待つ。

7.PC側、IPアドレスを[自動]に変更

シリアルコンソールを使わなくても、ファームの書き換えが出来ました。

4 件のコメント :

  1. 転送を実行すると、読み取れないとエラーが出るのを直すにはどうすればいいですか?

    返信削除
    返信
    1. 何が「読み取れない」のか、
      arp,netshの設定が悪いのか、
      tftpの接続が悪いのか、
      ファームファイルの置き場所が悪いのか、
      こちらのコメントだけでは、わかりません。
      また、転送コマンドを入力するタイミングが非常にシビアです。
      コマンドをコピーしておいて、タイミングを微妙に変えつつ、ペーストで入力します。

      エラー番号のようなものは出ていませんか?
      または、正確なエラーメッセージを教えて下さい。

      削除
  2. 上記の方とは別なのですが、私もどうしても成功しません。メカに疎いので原因も判りません。
    エラーメッセージは「接続要求に失敗しました」のみです。特にエラー番号のようなものはありません。

    記事との差異は

    DLしたWZR-HP-AG300Hのexeを解凍しファームファイルのみを1フォルダに移す
    その際にファームファイル名がwzrhpag300h-173だったので転送も「tftp -i 192.168.11.1 put c:\1\wzrhpag300h-173」にする
    コマンドプロンプトに予めペーストしておきタイミングでenterする

    くらいでしょうか。
    osがwin10なのでTFTPを有効やIPアドレス固定はWin10向けページで調べました。
    よろしくお願いします。

    返信削除
    返信
    1. コメントありがとうございます。
      準備の手順が合っているとしたら、
      あとは、コマンド投入のタイミングが、非常に難しいです。
      >LAN1(PCに接続してある)LED 点灯 直後
      という表現をしていますが、
      >LAN LED 全部 点灯
      から数えて、1秒後とか、2,3,4,5秒後とか、秒数を変えてみては、
      どうでしょうか?
      当方は、他の方の成功例を見てやってみましたが、
      すぐにはできず、10回目で、やっと出来ました。

      削除